Using C language to solve the string matching problem

  • 2020-04-02 03:14:20
  • OfStack

The most common approach is to use the KMP string matching algorithm:


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int get_nextval(char *pattern, int next[])
{
  //get the next value of the pattern 
  int i = 0, j = -1;
  next[0] = -1;
  int patlen = strlen(pattern);
  while ( i < patlen - 1){
    if ( j == -1 || pattern[i] == pattern[j]){
      ++i;
      ++j;
      if (pattern[i] != pattern[j])
        next[i] = j;
      else
        next[i] = next[j];
    }
    else
      j = next[j];
    }

  return(0);
}

int kmpindex(char *target, char *pattern, int pos)
{
  int tari = pos, pati = 0; 
  int tarlen = strlen(target), patlen = strlen(pattern);
  int *next = (int *)malloc(patlen * sizeof(int));
  get_nextval(pattern, next);
  while ( tari < tarlen && pati < patlen ){
    if (pati == -1 ||target[tari] == pattern[pati]){
      ++tari;
      ++pati;
      }else{
        pati = next[pati];
      }
  }  
if(next != NULL) free(next);
next = NULL;
if (pati == patlen)
  return tari - pati;
else
  return -1;
}


int main()
{
  char target[50], pattern[50];
  printf("imput the target:n" );
  scanf("%s",target);
  printf("imput the pattern:n" );
  scanf("%s",pattern);
  int ans = kmpindex(target,pattern,0);
  if (ans == -1)
    printf("errorn");
  else
    printf("index:%dn",ans);
  return 0;
}


exercises
      Title description:  
              Read in the data string[], and then read in a short string. It is required to find all matches between string[] and short string, and output line number and matching string. Matches are case-insensitive and can have a pattern match represented by brackets. For example, "aa[123]bb" means that aa1bb, aa2bb and aa3bb are all matched.  
      Input:  
      The input has multiple sets of data.  
      Enter n(1) in the first row of each set of data < = n < =1000), starting with the second line, enter n strings (no Spaces), then enter a matching string.  
      Output:  
      Outputs the line number of the matched string and the string (matching case insensitive).  
      Sample input:  
      4  
      Aab  
      a2B  
      ab  
      ABB  
      A [a2b] b  
      Sample output:  
      1 Aab  
      2 a2B  
      4 ABB  


Ac code

 


  #include <stdio.h> 
  #include <stdlib.h> 
  #include <string.h> 
    
  #define MAX 1001 
  #define LEN 101 
    
  struct str 
  { 
    char name[101]; 
  }; 
    
  int main() 
  { 
    struct str strs[MAX]; 
    struct str t[LEN]; 
    int i, n, len, j, k, left, right, count, flag; 
    char text[LEN], newtext[LEN]; 
    
    while (scanf("%d", &n) != EOF) { 
      //Receive data
      getchar(); 
      for (i = 0; i < n; i ++) { 
        scanf("%s", strs[i].name); 
      } 
    
      //Received text string
      getchar(); 
      gets(text); 
      len = strlen(text); 
    
      for (i = left = right = 0; i < len; i ++) { 
        if (text[i] == '[') { 
          left = i; 
        } else if (text[i] == ']') { 
          right = i; 
          break; 
        } 
      } 
      count = right - left - 1; 
    
      if (count <= 0) {  //No regular match
        for (i = j = 0; i < len; i ++) { 
          if (text[i] != '[' && text[i] != ']') { 
            newtext[j ++] = text[i]; 
          } 
        } 
        newtext[j] = '0'; 
        for (i = 0; i < n; i ++) { 
          if (strcasecmp(strs[i].name, newtext) == 0) { 
            printf("%d %sn", i + 1, strs[i].name); 
          } 
        } 
      }else { //You need regular matching
        for (j = 1, k = 0; j <= count; j ++, k ++) { //Building a text array
          memset(t[k].name, '0', sizeof(t[k].name)); 
          for (i = 0; i < left; i ++) { 
            t[k].name[i] = text[i]; 
          } 
          t[k].name[i] = text[left + j]; 
          strcat(t[k].name, text + right + 1);   
        }   
        
        //Regular match
        for (i = 0; i < n; i ++) { 
          for (j = flag = 0; j < count; j ++) { 
            if (strcasecmp(strs[i].name, t[j].name) == 0) { 
              flag = 1; 
              break; 
            } 
          } 
          if (flag) { 
            printf("%d %sn", i + 1, strs[i].name); 
          } 
        } 
      } 
    
    } 
    
    return 0; 
  } 

      / * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
              Problem: 1165
              User: wangzhengyi
              Language: C
              Result: Accepted
              Time: 0 ms
              Memory: 948 KB
      * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * /


Related articles: